install afpd on hp microserver + ubuntu

version 3.1.6 reference : http://netatalk.sourceforge.net/wiki/index.php/Install_Netatalk_3.1.7_on_Ubuntu_14.10_Utopic

apple제품군의 프로토콜이 업그레이드 되면서 2.2.2를 사용하기 위해 직접 컴파일해서(패키지를 사용하지 말고) 써야 한다고 한다. 2.2.2이후부터는 avahi deamon을 사용하지 않는다고 한다.

reference : http://bibo-log.blog.so-net.ne.jp/2012-03-16

sudo apt-get build-dep netatalk
wget http://sourceforge.net/projects/netatalk/files/netatalk/2.2.4/netatalk-2.2.4.tar.gz
tar zxvf netatalk-2.2.4.tar.gz
cd netatalk-2.2.4
./configure --enable-debian
make;sudo make install
/usr/local/sbin/afpd -V
ln -s /usr/local/etc/netatalk/ /etc/netatalk

필요없는 서비스는 설정에서 주석을 지워 서비스를 해제한다.

vi /etc/default/netatalk

ATALKD_RUN=no
PAPD_RUN=no
TIMELOAD_RUN=no
A2BOOT_RUN=no

timemachine을 사용하기 위해서 몇가지 셋팅을 추가한다.

sudo mkdir /var/timemachine
sudo chmod 777 /var/timemachine
sudo vi /etc/netatalk/AppleVolumes.default

/var/timemachine "timemachine" allow:[username] options:usedots,tm

글쓴이

yupmin

Inside Deep Throat.

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다

This site uses Akismet to reduce spam. Learn how your comment data is processed.